error code 43 on 2004 yamaha fz6... PLEASE HELP!!! - Yamaha FZ6 Forums - FZ6 Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-22-2013, 04:46 AM Thread Starter
Junior Member
 
DimeWylde's Avatar
 
Join Date: Nov 2013
Location: Dallas, TX
Posts: 1
error code 43 on 2004 yamaha fz6, bad battery cause this? PLEASE HELP!!!

hey guys, im new to the post and new to street bikes, this is my 2nd street bike in the last 3 months, im getting error code 43 on my speedometer gauge and it states in the manual that the power to the fuel pump and injectors are not correct, i can spray starting fluid into the breather and it starts up and runs and sounds very good until the fluid evaporates... all the lights work on the bike etc... my battery is completely bad on the bike, i have got to replace it which im about to do this weekend, is it possible that the bad battery is causing it not to get enough power to the fuel pump and injectors or its just causing it to throw the codes bc of lack of power, everytime i try and start it for the meantime i have to hook jumper cables up to it, i hope im not asking an ignorant question (i know nothing about bikes at all!!!) and would be greatly appreciated if someone could help me out with this issue, and in case your wondering i just bought the bike the way it is...

Last edited by DimeWylde; 11-22-2013 at 05:03 AM. Reason: to be a lil more specific about my problem
DimeWylde is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha FZ6 Forums - FZ6 Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome