Engine temp gauge broken - Yamaha FZ6 Forums - FZ6 Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-24-2018, 04:09 PM Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 1
Engine temp gauge broken

Hi there, looking for some guidance here as i am having trouble solving this. I have a 2005 FZ6. A couple months ago my engine temperature gauge quit working and at the same time the check engine light came on (assuming due to gauge/sensor). Now the bike will not start unless i put a heater on the engine for a while. So my basic assumption is that a temp sensor went out and now the computer doesn't know how to adjust the fuel/air ratio on a cold start. Once the engine is heated up and i can start it, get it good and warm then it runs like a champ and will start easily, but again, it requires putting a heater on the motor to get it warm at a cold start. Additionally, now the fan runs constantly whenever the bike is running, again, assuming this a safety back up mechanism by the computer trying to ensure the bike doesn't over heat since it cant read the temp. So my question is, where is the sensor that reads the engine temp? Would this be a sensor that screws into the block or a sensor on the whole fuel/air intake? Thanks for your help with this?
bradams115 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha FZ6 Forums - FZ6 Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome